Flutter plugin not installed error. When running flutter doctor

Hello Guys How are you all ? Hope you all are fine. When I first time installed flutter in My system. Then When we use android studio we have to use Flutter plugin in android studio. and then When I was try flutter doctor command I found Flutter plugin not installed; this adds Flutter specific functionality. in my console log.

So Here is all Possible Solution to solve this Error.

Question: How to solve Flutter Plugin Not Installed Error, When Run flutter doctor ?
Answer: Here Is Defined all Possible Solution to solve your Error. Just Follow Below Step.

What Is Error ?

I am configuring Flutter SDK on my Linux Ubuntu 16.4 system. Why am I getting the following error when I run the flutter doctor? I have specified both PATHS for flutter and dart in the .bashrc but I get this error when I run flutter doctor

Doctor summary (to see all details, run flutter doctor -v):
[✓] Flutter (Channel beta, v0.5.1, on Linux, locale en_US.UTF-8)
[✓] Android toolchain - develop for Android devices (Android SDK 28.0.2)
[✓] Android Studio (version 3.1)
    ✗ Flutter plugin not installed; this adds Flutter specific functionality.
    ✗ Dart plugin not installed; this adds Dart specific functionality.
[✓] IntelliJ IDEA Community Edition (version 2018.2)
[!] VS Code (version 1.25.1)
[!] Connected devices
    ! No devices available

! Doctor found issues in 2 categories.

Solution 1

Solution that worked for me:

  1. Just install plugins.
    Studio>>File>Settings>Plugins>Browse Repositories
  2. Search for flutter.
  3. Tap on Install (a dialog will pop regarding dart dependency. click Yes).
  4. Once the installation is finished restart android studio.

Solution 2

flutter upgrade

flutter config –android-studio-dir=”C:\Program Files\Android\Android Studio”

flutter doctor -v

then if the issue still persistes then just shift to the beta channel and the upgrade flutter then it will fix it.

flutter channel beta

flutter upgrade

Solution 3

The problem is with installing the required Flutter and Dart plugins. There are two ways in which you can achieve this:

  1. Go to Android studio → Settings → plugins → in the search bar search for Flutter and Dart plugins.
    If you are installing flutter first, then Dart may get automatically installed along with it, otherwise install them separately.
  2. If you are using VScode, in the activity bar click on extensions or press Ctrl + Shift + X. There you can search for flutter and dart plugins.

So Hope This Above 3 Solution Will Work For You Too. So it’s all About Flutter plugin not installed error. When running flutter doctor error. Hope this tutorial helped you a lot. Comment below Your thoughts and your queries. And Also Comment on your suggestion here.

Also Read

Milan Dhameliya is an Information Technology Engineer. By profession, he is a Full Stack developer with knowledge of multiple back-end platforms (e.g., PHP, Node.js, Python) and frontend Flutter frameworks.

6 thoughts on “Flutter plugin not installed error. When running flutter doctor”

Leave a Comment