close

[Solved] Could not resolve all artifacts for configuration ‘:image_picker_android:debugUnitTestRuntimeClasspath’

Hello Guys How are you all? Hope You all are fine. When trying to run my flutter project I am facing the following error Could not resolve all artifacts for configuration ‘:image_picker_android:debugUnitTestRuntimeClasspath’ in a flutter. So today Here I come with all possible solutions for this error.

We are providing you with all possible solutions to solve this error. let’s start this article without wasting your time.

How Could not resolve all artifacts for configuration ‘:image_picker_android:debugUnitTestRuntimeClasspath’ Error Occurs?

When trying to run my flutter project I am facing the following error.

Could not resolve all artifacts for configuration ':image_picker_android:debugUnitTestRuntimeClasspath'. Failed to transform bcprov-jdk15on-1.68.jar (org.bouncycastle:bcprov-jdk15on:1.68) to match attributes

How To Solve Could not resolve all artifacts for configuration ‘:image_picker_android:debugUnitTestRuntimeClasspath’ Error?

  1. How To Solve Could not resolve all artifacts for configuration ':image_picker_android:debugUnitTestRuntimeClasspath' Error?

    To Solve Could not resolve all artifacts for configuration ':image_picker_android:debugUnitTestRuntimeClasspath' Error You Need to use dependency overrides for a plugin image_picker_android Add This line in your pubspec.yaml file: image_picker_android: 0.8.4+13 Now, You can run your flutter app and your error must be solved now.

  2. Could not resolve all artifacts for configuration ':image_picker_android:debugUnitTestRuntimeClasspath'

    To Solve Could not resolve all artifacts for configuration ':image_picker_android:debugUnitTestRuntimeClasspath' Error You Need to use dependency overrides for a plugin image_picker_android Add This line in your pubspec.yaml file: image_picker_android: 0.8.4+13 Now, You can run your flutter app and your error must be solved now.

Solution 1: Use dependency overrides

You Need to use dependency overrides for a plugin image_picker_android Add This line in your pubspec.yaml file.

dependency_overrides:
  image_picker_android: 0.8.4+13

Now, You can run your flutter app and your error must be solved now.

Conclusion

So, It’s All About This Error. I hope this tutorial helps you to Solve your error. Please Comment Below if You stucks anywhere with my code. And please comment below on which solution worked for you. Thank You.

Also, Check Out the Below Tutorials

Leave a Comment